0

At at the momentent I´m investigating a problem with the people picker in my new domain.

Environment:

Old: OldDomain.com

New: NewServiceDomain.root.com (For Serviceaccounts) and NewUserDomain.root.com (For user accounts)

The forrest is root.com

A oneway trust exist between the old an new domain. The Firewall on the SharePoint Server is off.

Problem: When I´m installing a new SharePoint Environment in the NewServiceDomain.root.com the people picker is not showing up the accounts from the NewUserDomain.root.com but is showing up account from the old domain and the NewServiceDomain.

I tried already many compinations with stsadm command for the people picker:

I think this is the right command for my environment: stsadm –o setproperty –url Url –pn peoplepicker-searchadforests –pv “forest:root.com;domain:OldDomain.com

What is the right command? Andy ideas to solve this problem?

Many thanks in advance!

1

Since you have a one way trust you need to use username and password as shown below:

"Specify user account and password from a one way trust To specify the user name and password from a one-way trust, so that People Picker can look up this information, use the following syntax: stsadm -o setproperty -url http://<server:port> -pn peoplepicker-searchadforests -pv "forest:contoso.corp.com,<LoginName>,<Password>;domain:bar.contoso.corp.com,<LoginName>,<Password>""

See this Technet article for details. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.