0

When I add new item my custom list I got error. How can I solve this problem? I stopped then started IIS but the problem is continuing.

enter image description here

  • Did you check the ULS Logs? – Sathiya Apr 24 '17 at 11:25
1

This is basically due to low memory.

First, Try by restarting the SharePoint server.

If issue still there then Restart the SharePoint Search Host Controller in services.msc

You can even change the minFreeMemoryPercentageToActivateService to 0 in Web.config file follow the below steps to do it:

Open IIS Manager on SharePoint server and do the following steps:

 a. Right Click on “Web Application” where you are getting error.
 b. Explore the Web Application.
 c. Open Web.config file.
 c. Search for serviceHostingEnvironment under system.serviceModel
 d. modify the entry as follows:

<serviceHostingEnvironment aspNetCompatibilityEnabled="true" minFreeMemoryPercentageToActivateService="0"/> .

 e. Save the Web.config
 f. Reset IIS. 

Hope this helps

  • Anuja thanks for advice, I restarted the ISS again, problem is solved. – zengel Feb 26 '15 at 12:31
  • Mark it as answer if this helped you – Anuja Feb 27 '15 at 4:37
0

There can be multiple causes for that.As already you have restarted IIS.Try following things

  1. Go to your SharePoint Server
  2. Start
  3. Run
  4. Type – services.msc
  5. It will open the services console
  6. Search for this service - SharePoint Search Host Controller
  7. Restart it.

    This issue mostly occurs when a server memory drops below certain level so permanent solution would be adding more memory to your server or closing some unused programs running on the server.

http://www.c-sharpcorner.com/Blogs/46538/sharepoint-2013-error-the-server-was-unable-to-save-the-fo.aspx

  • Amit Kotha thanks for advice, I restarted the ISS again, problem is solved. – zengel Feb 26 '15 at 12:32
0

Check your IIS-binding and your AAM Public URL Zone.

For example:

Our FQDN is: intranet.domain.com

  1. Then navigate to IIS-binding (IIS Manager > Sites > select the site that were the error occurs on. > Bindings.)

  2. In this case, the Host Name should be: intranet

  3. Then check the Alternate Access Mapping (SP Central Administration > Configure alternate access mappings > Edit Public URLs

  4. Edit Default: intranet.domain.com

Hope this works!

It did the job for me! :)

//Dannti

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.