3

I am trying to create a textbox in info path form with following criteria:

1.) Length should be 1-50 characters .

2.) It should not contain any digits.

3.) It should contain only letters from the alphabet.

I tried the following pattern but it's not working

FieldName | does not math pattern | [a-zA-Z]{1,50} | or
FieldName | does not math pattern | .*[a-zA-Z].*   | 

following regex pattern work with allow special characters, but does not work in Infopath form

^[^0-9]+$
  • To set the maximum character for a text box, right click and go to Text Box properties and click the display tab. Look for the checkbox called "Limit text box to: x Characters". – Christoffer Feb 26 '15 at 7:54
1

Following Custom Pattern Work for me.....

Field Name | does not match pattern | [a-zA-Z]([ ]*[a-zA-Z])*

enter image description here

  • If any one can let me know how a text box can only accept number but not letters? – AIM4DREAM Apr 13 '18 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.