1

I have setup a Multi-Tenancy Farm and everything seems to be working fine except for the fact that I'm getting Mixed Content when viewing my Site through SSL. The SSL is being offloaded to the load balancer.

I initially setup my Web Application with No Host Header on Port 80 and created my HNSC without SSL. Ex: test.sharepoint.com

I then extended my HNSC for SSL using this command Set-SPSiteUrl -Identity $site.Url -Url https://test.sharepoint.com -Zone Internet

This all seems fine but again when I login to the HNSC site i see these errors in my console.

Mixed Content: The page at 'https://test.sharepoint.com/_layouts/15/start.aspx#/SitePages/Home.aspx' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://test.sharepoint.com/_layouts/15/blank.js?rev=ZaOXZEobVwykPO9g8hq%2F8A%3D%3D'. This request has been blocked; the content must be served over HTTPS.
start.js?rev=XFhC2yBo1NQ183GJoVt%2ByA%3D%3D:1 
Mixed Content: The page at 'https://test.sharepoint.com/_layouts/15/start.aspx#/SitePages/Home.aspx' was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint 'http://test.sharepoint.com/ScriptResource.axd?d=OlE2pnmvhKwrlnyNyHlU0DG…q8kUMFW6luTJf9MpfjN8_ttt4hRXMWUbt_YhigcyzatfRl3LskVFhg0&t=ffffffffb53e74b8'. This request has been blocked; the content must be served over HTTPS.
start.js?rev=XFhC2yBo1NQ183GJoVt%2ByA%3D%3D:1 

...

I'm wondering what i have to do to fix this issue. Any help is appreciated!

Adam

  • did you try different browser? – Waqas Sarwar MVP Feb 20 '15 at 18:35
  • Yes I've tried Chrome, IE and Firefox .. all reporting the same issues. – adha409 Feb 20 '15 at 18:47
  • I'm no network guy, but I thought if you were offloading ssl to the load balancer, you didn't need to ssl the Sharepoint servers – Eric Alexander Feb 20 '15 at 18:50
  • and is the load balancer using sticky sessions – Eric Alexander Feb 20 '15 at 18:52
  • I'm no network guy either but I thought you at least had to setup the URL mappings within SharePoint but I could be mistaken. – adha409 Feb 20 '15 at 19:05
-1

Mostly it is related to the Browser you are using, before their was an issue with chrome. Also what is URL for the default zone, are you using Http or Https? May be that's your issue.

have a look on these.

https://stackoverflow.com/questions/18251128/why-am-i-suddenly-getting-a-blocked-loading-mixed-active-content-issue-in-fire

https://social.technet.microsoft.com/Forums/office/en-US/083dfb43-3a3f-437c-b10a-3554fa8cac54/sharepoint-2013-ms-office-web-apps-owaps-google-chrome-mixed-content-error?forum=sharepointgeneral

  • I even changed the Default zone of my HNSC to be https and no change. I was mainly curious if i needed to setup the Web Application as SSL by default but i wanted to confirm there is no other way to fix this first before i did that. – adha409 Feb 20 '15 at 18:48
  • what are the AAM settings for the web App? – Waqas Sarwar MVP Feb 20 '15 at 18:49
  • I didn't set any additional AAM's for the web app... could that be my issue? There is currently just the default zone at port 80 currently set. – adha409 Feb 20 '15 at 19:00
  • Actually the web application is setup on port 81 as I had another web application that was currently using port 80. I assume that isn't part of my issue as everything is working except for this Mixed Content issue I can't resolve. – adha409 Feb 20 '15 at 19:10
  • do you have any customization on the site? looks JS file loading from the http....check this to understand it blogs.msdn.com/b/ieinternals/archive/2009/06/22/… – Waqas Sarwar MVP Feb 20 '15 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.