1

I'm a developer that was charged with correcting an intermittent problem with searching on our production 3 APP, 2 WFE SharePoint 2010 farm - I corrected this by restarting the 'Search Query and Site Settings Service' on each server that was assigned the Query component.

As I investigated this problem I noticed that the ULS logs had increased in size by a factor of 10-20, due to verbose logging entries flooding the log for the Setup and Upgrade category. It seems that the problem has been happening for at least the last few days - I do not have the logs prior to this.

02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     OfficeServerProducts.IsInstalled    7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     Searching to see if office server product id 110D is installed  7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     OfficeServerProducts.OfficeProductList  7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     OfficeServerProducts.OfficeProductList  7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     OfficeServerProductToProvision.IsEqual  7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     Trying to see if product id 110D is equal to the product id in guid ########-####-####-####-0000000ff1ce    7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     We are tying to see if guid ########-####-####-####-0000000ff1ce is an office server guid with a product id of 110D 7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     Major version for the guid is 14    7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     office family id for the guid is 0000000ff1ce   7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     Product id for the guid is 1080 7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     The products are NOT equal  7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     OfficeServerProductToProvision.IsEqual  7c56b5cc-1ad8-4b61-9008-613da1e582a2  
02/20/2015 09:09:02.05  w3wp.exe (0x1D64)                           0x0C24  SharePoint Server               Setup and Upgrade               apiu    Verbose     OfficeServerProductToProvision.IsEqual  7c56b5cc-1ad8-4b61-9008-613da1e582a

2

No upgrade has been started, and the only change to the servers were Microsoft security updates that were installed on 25/01/2015. The farm is running build 14.0.6029.1000, which is SP1.

According to this site http://www.tripwire.com/state-of-security/security-data-protection/sharepoint-patch-components/, product 1080 is the SP2013 English Language Pack, however the farm is SP2010 and all components on the Manage Patch Status in Central Administration report version 14.0.6029.1000.

According to this site http://idocs.info/the-search-request-was-unable-to-connect-to-the-search-service/, whose comments seem to have the same verbose logging problem, the original poster believes a service application is causing the problem - however all service applications in my farm seem to be running OK.

I have ran stsadm localupgradestatus, again with nothing that could explain the verbose logs:

[8] content database(s) encountered.
[0] content database(s) still need upgrade or cannot be upgraded.
[21] site collection(s) are contained in the content databases.
[0] site collection(s) still need upgrade.
[53] other objects encountered, [0] of them still need upgrade or cannot be upgraded.

There are no windows events that appear related to the verbose ULS logs. I have ran a clean virus scan on all servers in the farm using Sophos Protection. The Upgrade Status in Central Administration reports there are no upgrade items. Finally there does not seem to be any affect on the site-collections in the farm.

I need assistance in two parts if possible - firstly if this is an upgrade that is occurring what would have started this automatically or what is causing the error and secondly how can I remove the error or cancel the upgrade that is generating the verbose logs?

Thanks for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.