1

I had notice that in SharePoint Online, when I create a content type in the content type hub (http:/my.sharepoint.com/sites/contentTypeHub/), the site collections created before the content type never subscribe to the hub. But if I create a new site collection, after the content type is created, then that site collection show the content type immediately.

  • 1
    The content type hub is created as one of the base site collections when a SPO tenant is established and any site collection should be subscribing to it by default. What is one of these site collections that is not picking up the change? – Eric Alexander Feb 20 '15 at 14:20
  • I think I found the problem, but let me wait some more minutes to see if the content types appears at the old site collections. I wasn't publishing the content types. I thought that the content type publish automatically when created since at the "Manage publishing for this content type" I was seeing "publish" and that confuse me to think that it was already published. – iDevFS Feb 20 '15 at 14:52
  • Ya it needs to be published at the hub for the subscribers to pick it up, if that is your problem, put that as an answer so it can be accepted – Eric Alexander Feb 20 '15 at 14:59
2

So if this is happening to you you should first publish your content type, at your content type hub. From there you should click "Manage publishing for this content type" and you will see 3 options:

Publish Make this content type available for download for all Web Applications (and Site Collections) consuming content types from this location.

Unpublish Make this content type unavailable for download for all Web Applications (and Site Collections) consuming content types from this location. Any copies of this content type being used in other site collections will be unsealed and made into a local content type.

Republish If you have made changes to this content type, the content type needs to be "republished" before the changes are available for download to Web Application consuming content types from this location.

If no date/time is shown at "Last successful published date:" and the Unpublish and Republish options appeared to be hidden/grayed then you have to publish the content type. To do that just click Ok, and the same to the popup. Then you need to go to Site settings > Content type publishing and make sure "Refresh all published content types on next update" is selected and click Ok. After that just wait like 15 minutes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.