1

I've got a 2013 workflow that looks up a value in another list based upon the value in a managed metadata column. It was based on this discussion. And it is working if the column is restricted to one value.

If the managed metadata column allows multiple values the workflow doesn't function properly. I'm able to get the value from the column into a string which looks something like this when logged to the workflow history:

term1|guid1;term2|guid2;term3|guid3;

I have an action that finds the pipe character, but it always returns -1 -- meaning that it doesn't find a match. But I can clearly see the pipe. I have also tried various letters and numbers which are also present, but no match is ever found.

Any idea how to work with multiple value managed metadata columns in 2013 workflows?

Update: Found another tutorial​ on how to make a custom activity for the workflows. I don't have visual studio or the knowledge to make a custom activity, but I want to put it here as another clue.

  • I get the same problem, have found a solution ? – barbuslex Mar 5 '15 at 9:27
  • Nope. Our SP support guy is going to ask the MS engineer next time they have a support call. Other than that I've got nothing. Found lots of tutorials on how to set them, but none on how to read them. – Rothrock Mar 5 '15 at 15:27
  • @Rothrock, I know this is suuuper late, in the scheme of things, but have you found a solution to this? I know how to dig into the format of those metadata terms, but it's a pretty specific use case, so I'd have a couple of follow up questions. – ChrisPEditor Jul 7 '16 at 15:28
  • Wow that has been a long time. No we never found a way to make this work. Frankly I don't even remember what we were trying to do, but it couldn't be done with the techniques I found. What've ya got? – Rothrock Jul 7 '16 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.