2

I followed the 3 page tutorial here to get the current Display Name in an infopath textbox. https://spvee.wordpress.com/2013/04/10/auto-populate-user-information-in-infopath-with-claims-based-authentication-part-1-of-3/

After several tries I narrowed down the problem to something very specific.

It always shows the Display Name of the user used in the Credentials in the secure store service application. It doesnt use the current user.

I do have access to the farm, but I didnt not install it, so am not aware if something is wrong on IIS/App Pools or service applications.

Any idea??

  • Any luck with this? I am also facing similar issue – Mihir Jul 10 '18 at 22:42
1

Ok.. so I have used this function quite a bit and what I suspect might be the issue is in your data connection "automatically retrieving the data when the form is loaded".

My rules are like this:

Don't automatically retrieve data on my data connection. On form load, use the User Profile data connection to query (Query data source) Then set the AccountName to whatever function or value you want.

Then I'd have a rule on your textbox that has the condition "If [textbox] is empty", Action > Set a fields value > [Textbox] and follow the rest of the steps to set the display name.

Here is another post that steps you through the issue you're experiencing that I hope will also be of use!

https://bobbyschang.com/2011/09/11/infopath-gotcha-user-profile-displaying-admin-user/

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.