5

I'm trying to create a workflow for a newsfeed and I'm having issues getting it to start.

Workflow steps is to log message to history list, send email, and log sent message. I've used the same steps testing a regular list and the workflows complete without issue.

The workflow gets stuck in 'Started' status. The error it gives is

Details of last request: HTTP Unauthorized to http://site/_vti_bin/client.svc/web/lists/getbyid(guid'GUID')

If i copy/paste this into the browser I can see the info just fine.

After a time it gets set to suspended status

HTTP 401 {"error":{"code":"-2147024891, System.UnauthorizedAccessException","message":{"lang":"en-US","value":"Access denied. You do not have permission to perform this action or access this resource."

I've tried setting permissions on the list, but have not had any successful results.

1

I was in a similar situation where users with full control could run the workflow to completion, but contribute and under the workflow would end up cancelled. None of the common answers provided (App Step, App Permissions, User Profile sync Application, Applicaiton pool Settings, etc) worked for me.

The big issue was with the workflow configuration itself. Be sure that the "Automatically Update The Workflow Status To The Current Stage Name" box is unchecked in SharePoint Designer

The issue

Kudos to Paul Culmsee for the information HERE

In SharePoint Designer 2013, there is an option to disable the updating of stage information. In the workflow settings screen, look for the option called Automatically update the workflow status to the current stage name and untick it.

  • I applied same, however not succeed. Can u share another fix for it? – Manveer Singh Sep 18 '17 at 12:42
0

Just looking at the error message one can easily say ,it is something related to Authentication, After digging out so much inside every possible reasons and banging my head against the wall for a couple of hours , finally I noticed that the user account which has used for security token service AppPool has not enough rights on UPA, So I changed that account to the same account that is being used for UPA .Republished the workflow again and ran a test , BOOOM it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.