I've been trying to start UPS Sync Service in my SP2010 Farm.

Here what I do:

  1. Create a UPS Sync Service Application with a managed account (DOMAIN\spservices).
  2. Click on newly created application, then Administrators from the Ribbon. Add farm account with full control (DOMAIN\spfarm).
  3. Go to Central Admin. > Services on Server
  4. Click Start button next to the UPS Sync Application

Right at this point it shows me a completely irrelevant managed account (DOMAIN\spsql). The field is disabled and I don't know how to change it.

  1. I try anyway, first it turns to "Starting" and after a few refreshes it stops with "Stopped"

I carefully tried to follow the steps explained here: http://www.harbar.net/articles/sp2010ups.aspx

Any ideas?

2 Answers 2


The account you see there is the Farm account that runs the service. YOu can NOT change this. The service is what the Service Applciation talks to and has nothing to do with the account you added to the service app's admininistrators).

To actually perform a user profile import from AD you CAN define your own account (which should have replicate directory changes permissions in your AD).

To get passed the starting..., add the spsql account to the local machine's Administrators group, start the service, wait till it's done (might take a while!) then remove the account from the admin group again.

  • 1
    important edit to what @colin writes (which essentially is what i described as Answer in your other question): local administrative permissions will NOT work for already started processes, hence all services running in farm admin context does not get the admin permission before those processes are restarted! Hence I recommend either a restart of all NT services running farm account credentials, or (recommended) reboot server after assigning local admin permissions, before trying to start the sync service instance! Commented May 23, 2011 at 11:02
  • +1 for the quick start tip. But the strange thing is, spsql is already a local admin and unfortunately giving it replication permission didn't solve the problem.
    – frbry
    Commented May 23, 2011 at 11:02
  • @Anders, thank you very much. Rebooting after doing the things Colin said solved the problem.
    – frbry
    Commented May 23, 2011 at 11:19
  • The spsql does not need replicate directory changes, the account you entere for a sync connection does!
    – Colin
    Commented May 23, 2011 at 11:25

Here are some STSADM commands to update/sync Active Directory with SharePoint Users. Please give them a try:

stsadm –o sync –listolddatabases 0
stsadm –o sync –deleteolddatabases 0
stsadm –o sync –synctiming m:1
stsadm –o sync –sweeptiming m:1
stsadm –o sync –excludewebapps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.