2

I am trying to deploy a SharePoint 2010 reusable workflow through SharePoint Designer 2013. Currently I am doing the below steps:

  1. open the site in SharePoint Designer 2013 [ http://serevr1:123/sites/engineering ]
  2. upload the workflow template[ myworkflowtemplate.wsp ] file in the solutions gallery and activate the same [ using import files option in SPD ]

  3. right click on the wf and click edit the workflow

  4. click on the ribbon in SPD's "publish the workflow globally"

  5. associate the WF to "mycustomcontenttype"

can anyone please help how this can be achieved using power shell. help is appreciated.

  • Please try to pay just bit attention to structure of your questions, you will get help quicker if people can read your question also before moderation. Thank you. – Jussi Palo Feb 13 '15 at 7:57
  • @JussiPalo thanks for your comment.But i have already mentioned the steps in a detailed manner. – SaMolPP Feb 14 '15 at 10:41
  • So you have saved workflow as a wsp and now wants to upload and activate onto the SharePoint site right? Is my understanding correct? – Asad Refai Apr 27 '15 at 13:40
2

If the workflow is saved as a template and we have a wsp file of it, then we can use simple PowerShell script for adding a solution and activate it.

Add a solution:

Add-SPUserSolution -LiteralPath <LiteralPath> -Site <SiteURL>

Install a solution:

Install-SPUserSolution -Identity <Solution> -Site <SiteURL>

Activate a solution:

Enable-SPFeature -Identity <Feature> -Url <URL>

You can refer the following useful forum and blog:

TechNet Forum

TechNet Blog

  • No Problem.. Happy yo help :) – Asad Refai Apr 28 '15 at 9:57
  • My workflow have impersonal steps. The workflow will run on behalf of who "publish" the workflow. In the case of "enable-SPFeature" how can we specific the "publisher"? – Mark L Sep 17 '15 at 8:53
  • @Mark : I have never tried this as Enable-SPFeature do not have any such parameter. But try this on the server containing your SharePoint, put your self into local admin group. Open PowerShell ISE in run as another user mode (give your credentials). And run the script. – Asad Refai Sep 17 '15 at 11:07
  • 1
    @AsadRefai I asked the same question in MS forum and the support told me the only way is connect with SPD and publish the workflow with specific "publisher". It seems Powershell method cannot handle impersonal SDP workflow – Mark L Sep 21 '15 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.