0

Dealing with an installation of SharePoint Foundation 2010 (14.0.7143.5000) that was included with Small Business Server 2011.

Everything worked fine yesterday, until the latest cumulative update (KB2910904) was successfully installed overnight by Windows Update. Now, all SharePoint sites and pages come back with the error below.

I tried running psconfig -cmd upgrade -inplace b2b -wait, which completed successfully but didn't fix the problem. (EDIT: doing that took down Central Administration as well)

As a test, I also tried restoring the pre-update web.config files, but that did nothing.

The Windows logs are equally unhelpful, logging one warning (1310) whenever I try to load a page in my browser.


Server Error in '/' Application.

Parser Error

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Object reference not set to an instance of an object.

Source Error:


[No relevant source lines]

Source File: none    Line: 1

Version Information: Microsoft .NET Framework Version:2.0.50727.5485; ASP.NET Version:2.0.50727.5483


UPDATE: I tried resetting the farm account password, but still no dice. I was able to log in with SQL Server Management Studio as the farm account, but I still get blood in the logs (3760). This guy was having the same issue as me, but didn't get anywhere either.

  • What errors are you getting in ULS Viewer? Are you able to pull up Central Admin? Any errors shown there? – jpollar Feb 11 '15 at 18:10
  • No, now Central Admin is giving me the same Parser Error message. The only things I can find in the ULS Viewer that look like errors are "The application domain /LM/W3SVC/2102256223/ROOT-23-130681524180405292 is unloading and going to be recycled," and then "Shutdown Reason: Initialization Error HostingEnvironment initiated shutdown HostingEnvironment caused shutdown." – reversedelta Feb 11 '15 at 18:24
  • What does ULS Viewer say? Check for Urgent errors. They should be highlighted in red. – jpollar Feb 11 '15 at 18:26
  • Nothing is Urgent. Everything I see is either High or Medium. I'm looking at older logs right now to see if there was anything logged during the update last night. – reversedelta Feb 11 '15 at 18:30
  • Good idea. You may just need to re-install. – jpollar Feb 11 '15 at 18:33
1

SOLVED! Months ago, I applied a custom patch to the compat.browser files to support Safari 8 and iOS 8. Despite this update not touching that browser file, the change still broke it.

I reverted to the previous compat.browser file (dated 2/11/2014) for each site, and SharePoint came back to life. Then, I added this different patch to make Safari 8 happy.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.