6

I'm having a problem when provisioning a new user's MySite. I'm trying to activate a feature that adds library / lists to the current user. The library / list should use a content type from the hub!

Problem is that the content type isn't in the user site collection when I'm running the feature (feature-stapling). It creates the list / library but not with the right content type. If I delete the lists and run the feature again, everything works perfect!

I've tried in the feature to run the timer job (content type subscription and content type hub) but it does not finishe before I run the rest of the code.

Anyone with the same problem?

3

I found the solution. Forgot to publish the content type and run the timer job (content type hub & subscriber). After that everything worked!

I don't have to run the timerjobs in the feature (code), it works without it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.