0

I am facing issue of VS not detecting my sharepoint site url. I know how to fix it, but why bug is not still solved properly ?

According to this blog, I should add it to host files, but when i ping my site using this,

portal.fruitfactory.com

ping works, but it doesn't work in visual studio as you see above.

My network admin says I don't need to add address to the host file point to 127.0.0.1, so why do i need to add it?

  • Screen shot is from the blog post and not from your environment, which is a bit confusing. – Jussi Palo Feb 9 '15 at 9:43
  • @JussiPalo removed it – Mathematics Feb 9 '15 at 12:01
  • Voting for close as it is Visual Studio bug and there already is a workaround. Please contact Microsoft Support regarding the issue and for ETA on the fix. – Jussi Palo Feb 10 '15 at 11:23
  • @JussiPalo Not asking for ETA, asking for if anyone knows if it has been fixed, if you can confirm that no one in this community knows that bug has not been fixed - I will accept your argument... – Mathematics Feb 10 '15 at 12:47
1

Based on my understandings...

When a new site collection is created it needs to add a registry key to SharePoint tools at this address,

[HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\11.0\SharePointTools]

But it doesn't adds it automatically, now if we add link to hosts file it does adds the link to registry key.

Again what I understood is that Visual Studio only looks at hosts files OR registry entry to detect your site collection.

I may be completely wrong but this is what I explained to my network admin.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.