2

I am trying to publish my InfoPath forms to the document library I created in sharepoint, I am getting this error every time I input the correct url of my web application (http://sptraining:40201) that host the document library.

enter image description here

When I try to input the url of my SharePoint Central Administration (http://sptraining:5555), I can proceed to next page, but this is not the proper web application that is why I am not continuing. You can see that the option for Administrator Approved form template (Advanced) is disabled.

enter image description here

I already searched an answer to many different sites but I cannot find anything :( I want to continue by inputting the proper url (http://sptraining:40201). Please help me

  • Please use InfoPath 2010 to publish your form! – Hamed Jul 17 '16 at 7:35
2

Can you please try steps given below?

  • Check Firewall Settings – Ports
  • Check Anti-Virus Client
  • Enable the "Allow management of content types" option. To do this:

    1. Open the document library
    2. Click "Settings"
    3. Click "Form Library Settings"
    4. Click "Advanced Settings"
    5. Click "Yes" under "Allow Management of Content Type"

Once it has been enabled, publish the form template as a "site content type" then add the form template to the document library that has been enabled to "Allow management content types".

If the above doesn't work, you can try this:

  1. Open the "Site Collection Administration settings"
  2. Select "Site content types" under "Galleries"
  3. Click on "Form"
  4. Click on "Advanced Settings". This screen will come up:

enter image description here

  1. If the "Enter the URL of an existing document template" has a value, just clear it to look like this:

enter image description here

  1. Create a new Form library.
| improve this answer | |
2

SharePoint InfoPath can't publish in 2013 the reason,

  1. Open "Library Settings"
  2. Click "Form Settings"
  3. In Form settings, the setting will be like below

enter image description here

You can't enable Last Option: Use a custom form created in InfoPath

Because in SharePoint 2013, Microsoft has removed from SharePoint List or Library.

If you are using previous version 2010 you can publish or else if you are using old version in SharePoint 2013 you can enable and publish the InfoPath.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.