1

I am using SharePoint 2013 OOTB, and can see that anonymous access to view the "entire site" is checked under site settings -> site permissions for anonymous users.

Why else would my search results web part not be displaying the same results on the page, that is shows when I do log in? It shows nothing when I am logged out.

I simply added the SharePoint search result web part from the ribbon, to my publishing page and gave it a custom search query.

Thanks for any advice on this

3
  • did you check the event viewer on the server and the ULS logs (in the "15 hive") to see if anything stands out (e.g. permission issues).?
    – Amit
    Feb 5, 2015 at 5:19
  • did you ever resolve this? Oct 20, 2015 at 17:12
  • Yeah, I think I overlooked the document library settings, or didn't wait long enough after a full crawl and/or SharePoint reset to make the search recognize the one document library (when logged out), and the other (when logged in).
    – klewis
    Oct 20, 2015 at 21:27

1 Answer 1

1

Could you try few steps give below?

  1. Reset your search index and then do a full crawl. Click below to know how to reset search index. Reset Search Index

  2. Disable lockdown feature on the site collection, disable anonymous access, then enable anonymous access again, full crawl of the website

  3. Web part indexing

    • Under the SharePoint Site go to Site Settings. Search Administration -> Search and offline availability -> Indexing ASPX Page Content, Enable the option "Always index all Web Parts on this site"

    • Under Search Service Application, do a Full Crawl for the content source to resolve this issue.

2
  • Also, I had to double check settings on each document library. In my specific case, I have multiple document libraries storing documents. and I think I overlooked the document settings...Thanks
    – klewis
    Oct 20, 2015 at 21:06
  • I also dropped a sharepoint search web part adn search results web part onto a publishing page. With that said, I am depending on custom search queries to show my results from specific document libraries. So that may also play a role in why things are working well now.
    – klewis
    Oct 20, 2015 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.