0

I’m experiencing an issue with a SSRS 2012 report integrated with SharePoint 2013 and it’s usage in Chrome and Firefox.

The issue presents itself when the following conditions are met. 1. User opens the report 2. User leaves the report idle for about 90 seconds 3. User then clicks on a toggle item

In IE, the report opens the toggle item as expected. However in Firefox and Chrome, the user ends up in a redirect loop, which sometimes ends in the user being brought back to the page as it was (not respecting the toggle item click) but in most cases it will simply loop through these redirects.

Using Fiddler and Firefox, it appears that the user is redirected to the logon.aspx page to re-authenticate and then is immediately redirected to the report page, just to be redirected back to the logon.aspx page again.

So far, we’ve tried the following to resolve without success

  • Enabling pass-thru / negotiate authentication in the browser settings

  • Changing the sessionstate timeout to a larger value in the reporting services web.config

    • Changing the sessionstate model to "stateserver" in the reporting services web.config
    • Changing the report session timeout setting in central administration.

Our environment is running SharePoint 2013 SP1 and we are using Effective User Name as well.

Has anyone run into this or have any suggestions to resolve?

0

"Enabling pass-thru / negotiate authentication in the browser settings"

What steps did you take for this?

I found these for these instructions to be helpful.

Setting up Firefox 3.x

Follow the steps below to configure automatic login in Firefox 3.x.

Open Firefox.
Type 'about:config' into your Firefox address bar.
When prompted, click 'I'll be careful, I promise'.
Find the following 'Preference Name': network.automatic-ntlm-auth.trusted-uris.
Right-click it and select 'Modify'.
The 'Enter string value' dialogue box will appear. Type the URL of your Confluence site and the URL(s) of your SharePoint sites, separated by commas. For example:
http://confluence.mycompany.com,http://sharepoint-url
Another example:
http://mycompany.com:8080/confluence,http://sharepoint-url-1,http://sharepoint-url-2
Replace the one or more sharepoint-url-x values with the addresses of the SharePoint site(s) hosting the Confluence web parts.
Click 'OK'.

https://confluence.atlassian.com/display/SPCON011/Setting+your+Browser+Options+for+Automatic+Login

  • I modified network.automatic-ntlm-auth.trusted-uris as you noted, but the issue still exists. – I am Erik Feb 3 '15 at 17:59
  • So it works for initial authentication...and then the connection drops after 90 seconds of inactivity? Is the user being prompted for credentials at anytime? – jpollar Feb 3 '15 at 18:02
  • that is correct. when the user initially hits the SP site they are given a challenge response, but after that they are never prompted for credentials again. – I am Erik Feb 3 '15 at 18:20
  • Pretty much as long as the user is actively clicking around in the report, all is good. but if they stop for more than 90 seconds it's game over for them. – I am Erik Feb 3 '15 at 18:21
  • Is SSRS running off a different URL maybe? Just trying to suss out where the connection is failing. – jpollar Feb 3 '15 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.