0

SharePoint Foundation 2010, patched to Nov 2014 CU

I have two web applications in this farm. A workflow from web application 1 sends an email. One of the recipients of the email is a list in web application 2. Emails are never delivered to the list in web application 2.

In ULS I see this error message for the particular email: Errors occurred processing 1 message(s): Message ID:

The list in web application 2 receives the same email content without problem when sent directly from a user.

If I open the problem .eml in the drop folder I see the following header: Received: from mysharepointserver.mydomain.local (1xx.xxx.xxx.xxx) by myexchange.mydomain.local (1xx.xxx.xxx.xxx) with Microsoft SMTP Server id 8.3.342.0; Mon, 2 Feb 2015 13:09:44 -0700

There are other 'Received' headers in the .eml.

If I delete the header that references mysharepointserver.mydomain.local and save the .eml, SharePoint will process it accordingly.

I am led to believe that SharePoint will not process an email that it thinks was sent by itself, probably in an attempt to prevent a never ending chain of sent/received emails.

Can anyone confirm this? Is there a workaround?

Thank You!

  • Microsoft.SharePoint.Administration.SPEmailEngine checks the following email headers using string.Equals: "X-AlertServerType", "STS" and "X-Mailer", "Microsoft SharePoint Foundation 2010". If either are found it will not process the email. – Lou Feb 3 '15 at 16:32
1

SharePoint cannot send email to itself:

http://thesharepointfarm.com/2013/03/sharepoint-cannot-send-mail-to-itself/

If you can strip out the X-Mailer value, then you'll be golden.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.