I am using a SharePoint Designer 2013 workflow attempting to use the "Get Items From A Dictionary" on JSON data obtained through a web service but it is always giving the error:

System.InvalidOperationException: Indexing by an integer value is not supported on an instance of 'Microsoft.Activities.Dynamic.DynamicPrimitive'.   at Microsoft.Activities.Dynamic.DynamicItem.get_Item(Int32 index)... (etc...)

The JSON data which I retrieve is as follows:


Get Items From a Dictionary is used with the following inputs:

Get (0)/FirstName from Variable: PanelMembers (Output to  Variable: CurrentFirstName)

Where (0)/FirstName is just text PanelMembers is of type Dictionary and CurrentFirstName is a string.

I am not sure what I am doing wrong... Any insights?

  • Try manually (may be via Fiddler) run request and check that you will get right data
    – Roman
    Feb 2, 2015 at 22:30
  • what is the web service URL that you are using to retrieve data?
    – Amit
    Feb 3, 2015 at 6:16
  • I am using a Qualtrics (a survey software) web service. The method getPanel specifically. The JSON data which I have posted above is what I took from logging the dictionary to the history list. And I have tested the web service using the chrome 'Advanced REST Client' app. Feb 3, 2015 at 16:52

1 Answer 1


4 years late to the party, but I just ran into this similar problem, where Advanced Rest Client worked, and my test flow worked, but when I implemented the same things in the actual flow, it threw that error. The difference between my test flow and being able to successfully get (0)/Parameter and the actual flow getting the "System.InvalidOperationException: Indexing by an integer value" error, was that in the actual flow I wrapped the Rest Call in an 'App Step'. When I went back to the test flow and wrapped everything as an 'App Step' I got the same error, and when I took it back out of the 'App Step' it worked as intended. If you have your rest call wrapped in an 'App Step', try doing it regularly instead of as an 'App Step' if that's what you have going on.

  • 1
    thanks for leaving an answer on such an old post, definitely have no way of verifying this answer anymore Mar 10, 2019 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.