1

Below is my scenario:-

  1. I have a main application(http://dev.example.com/en/) and it has its own content DB.
  2. I have search application inside the main application as a site collection(http://dev.example.com/sites/search) and it has its own search content DB.
  3. I need to deploy the above in my client's server, so i have taken the WSP package of the whole application and content DB of main application and search application.
  4. I deployed the main application and content DB in client server and it is working perfectly.
  5. And i created a site collection as(http://www.example.com/sites/search) and trying to restore the search content DB using the below script:-

    Restore-SPSite -Identity http://www.example.com/sites/search -Path "BACKUP_LOCATION\SEARCH_CONTENTDB.bak" -force
    

Once i run this in SharePoint Powershell as an Administrator, I get the below error:-

The operation that you are attempting to perform cannot be completed successfully. No content databases in the web application were available to store your site collection. The existing content databases may have reached the maximum number of site collections, or be set to read-only, or be offline, or may already contain a copy of this site collection. Create another content database for the Web application and then try the operation again.

Please let me know if am missing anything or if am deploying wrongly or i should do any specific configuration changes.

Your help is highly appreciated.

Thanks, Hudson

2

Can you try this:

Go to Central administration -> Application Management-> Database -> Manage Content Database. Select the required web application and click on Add Content Database. Give the name to this database.

Now restore the site collection to this database using Restore PowerShell Command:

Restore-SPSite http://sitename/sites/site_name -Path C:\Backup\site_name.bak -Force -DatabaseServer MyServer -DatabaseName MyDatabase
  • Thank you very much Nadeem, I followed the same as above, executed the restore script through SharePoint 2010 Management Shell and it worked Bingo!! You are a real superstar!! – Hudson Feb 2 '15 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.