0

Hi I have SharePoint portal in Azure, that I try to connect to my custom domain address.

I created and assigned static VIP to machine. Extended my Sharepoint application to internet zone, example mysite.cloudapp.net, set up it to use FBA authentication. Azure gives public name to machine so I accessed my site from internet via this address(by example "http://MySP.cloudapp.net"). All works.

Now I bought domain, created CNAME and A records few days ago, and added this address to Alternate Access Mappings in my SharePoint. By example it will be "http://MySP.com"

So alternate access mappings now are like this:

enter image description here

It works. But now if I type http://MySP.com, it changes in my browser to http://MySP.cloudapp.net. I don't want this, I want user to see only http://MySP.com(or http://www.MySP.com) header.

So I made backup and decided to delete http://MySP.cloudapp.net from AAM. After this if I type http://MySP.com I see in fiddler that there begins a loop and site does not open. I added it back but anyway got this loop. So now I restored and don't know - how to set up http://MySP.com address for this Azure SharePoint portal correctly?

I read this article, but it does not explain how to create two external addresses with no redirects http://blogs.msdn.com/b/sharepoint_strategery/archive/2013/05/27/alternate-access-mappings-explained.aspx

upd.: in addition I can say that I also added http://www.mysite.com in Alternate Access Mappings, and it also changes in browser url field to http://mysite.cloudapp.net

What can I do with this..

0

Resolved. Recreated web app and retuned FBA settings in web.config: "Update a web application URL and IIS bindings for SharePoint 2013"

https://technet.microsoft.com/en-us/library/cc262366(v=office.15).aspx

Not the way that I would call a "silver bullet", but this helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.