0

I can't get to the homepage of my site using just the root url, but it works if I specify the whole path. For example, this works fine:

http://server.domain.com/pages/page1.aspx

But the following results in "Sorry, this site hasn't been shared with you":

http://server.domain.com

While on page1.aspx, I clicked the "make homepage" button, and that gives me a success message.

SharePoint 2013 Enterprise, in a site using the publishing feature.

edit: this site has been around for months, and this problem just started today.

  • If you try to set the Welcome Page using Site Settings will it work? – Amal Hashim Jan 28 '15 at 20:08
  • No. But clicking "make homepage" did successfully update the setting in the welcome page. But I changed it in the welcome page and am still getting the same error. – Mike2500 Jan 28 '15 at 20:14
0

Have your admin check the permissions on the web application's virtual directory in c:\inetpub\wwwroot\wss\VirtualDirectories... We had something like this happen and it was a result of service pack change where the web app's virtual directory was rebuilt and the permissions were not correct.

0

A couple things to check:

  1. Is the home page checked in and published?
  2. Is the master page checked in and published?

Also, for the purposes of troubleshooting, try disabling Minimal Download Strategy feature.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.