5

We are using SP2013 on-premise. On a site collection there is a document library. There are several users with "Manage Permission" permission. Based on their need, they will change the permission on individual documents (permission inheritance is broken).

However, when they try to share the document to other users, the default permission level choice is always "contribute". Can we change the default choice to be "read only" and the "send email invitation" always off? It is because the permission level part is always hided. User need to click the "SHOW OPTIONS" to see the level choice. Users may grant the contribute permission level by mistake (and send email out).

enter image description here

  • Did you find a solution? I have similar issue. In my case default value is "Edit" access. – Rohit Jul 23 '15 at 7:13
  • Sorry, not yet. – Mark L Jul 23 '15 at 7:18
3

The alternative to the solution above is to use JS to set the default value. Add the flowing code block to the header section of your masterpage:

<script src="http://code.jquery.com/jquery-1.10.2.min.js" type="text/javascript"></script>
<script type="text/javascript">
$(document).ready(function () { 
    $("#ctl00_PlaceHolderMain_DdlSimplifiedRoles").val("role:1073741826");
    $("#ctl00_PlaceHolderMain_DdlGroup").val("role:1073741826");
})
</script>
  • How do you get the role:1073741826 number? – Mark L Oct 23 '15 at 1:18
  • @Mark A view source of the popup for two scenarios: Site Owner: <option value="role:1073741826">Can view</option> User: <option value="role:1073741826">Read</option> there will be an option for each role as a user and one other for can edit as a site owner – JonesEJ Oct 24 '15 at 13:19
  • @Mark if this solution worked for you please mark as the answer. Let me know if i can help more. – JonesEJ Oct 25 '15 at 7:47
  • Thanks. It works. To add more, we may also need: $("#ctl00_PlaceHolderMain_chkSendEmailv15").prop( "checked", false ); and $("#ctl00_PlaceHolderMain_Label_Aclinv_PageWelcomeMessage").text("Invite people to XXX"); – Mark L Oct 26 '15 at 3:18
  • I am also looking for ways to change behaviour to single page instead of entire site. By modify the Master page I have no choice but change entire site's behaviour. – Mark L Oct 26 '15 at 3:19
1

When you click on the "SHOW OPTIONS", SharePoint shows a drop down that contains Groups and Permission levels in sorted order.

The default permission in Invite people to 'xxx' is the permission of the first group/permission level.

I resolved this issue by creating a "_View Only" group. The underscore ensured that the group is first in the sorted order. You may use any other name, just ensure it is the first group listed.

  • I created a "_view" group. The group is the first in the sorted order. But the default selected group still "Contribute" which is 3rd in the drop-down-list. I tried several different library/document/item and sometimes "Edit" is the default. However I cannot figure out the pattern. – Mark L Oct 22 '15 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.