I've got one list where I had told it to quit using the infopath form, but didn't tell it to delete the infopath form.

Now, when i enter form settings for that list, it only shows the option to modify the existing infopath form.

How can i get the use Default form button back?

further examination...it may be because i threw the switch. I can open the form from infopath...and it's the old one i made...but there isn't a way to delete it from there, and if i attempt to publish at that point, i get an error that the list doesn't exist. grr

2 Answers 2


I'm not using anything like Nintex.

To resolve the issue, i went into the list via SharePoint Designer, and made a new form to be the default newitem form. Once i did that, I was able to circumvent things to get into InfoPath, upload my hand edited form.

after that, the radio buttons appeared again in form settings.


Do you happen to have any other form-editing tools installed in your SharePoint environment, such as Nintex Forms?

If you do have Nintex Forms installed, it can cause the list to retain its custom InfoPath form even after you've told the list to use the default form. To correct this, customize the item form with Nintex and choose the "Delete Form" option, which will force the list to use the default again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.