0

I'm a site admin, farm admin, every admin type that should give me permissions to have full reign over the site I'm working on. However, it seems that I'm unable to edit workflows in anything but Designer, and in Designer, I'm unable to publish these workflows particularly when I have checked to have the workflow start on item creation. I've even put myself in the lists manually that I'm creating workflows for as having full access. I've heard from some sources that you need to be a site collection owner to do this, while from other sources, it just says that you need to have edit permissions on the list you are creating the workflow for. I've tried logging in as the system user, but I still don't have workflow permissions. I've also heard from sources that this holds true particularly for the System user. I can make myself the site collection administrator, no problem. I want to make sure beforehand though that this is something I need to do or if I'm missing something else. I've tried logging in as the secondary site collection admin with no success, so I'm at a complete loss right now. I'd really like to create automatic workflows.

EDIT: I have tried logging into SharePoint designer as the System user and re-saving the workflow and trying to publish it with no results. I've also tried creating my own subsite with unique permissions and setting myself in a group of 1 with site ownership and contribution permissions. Even still, I am told that I do not have permissions to publish the workflow if I select to start the workflow on item creation...

0

If you login with System Account and even you give this user permissions as site collection admin, it's still a system account, did you try logging in with another user and try it out with? What errors did you have when doing that?

  • With Designer it's always: "You do not have permission to do this operation. Ask your site administrator to change your permissions and then try again, or log on with a user account that has this permission." when I try and publish it. If I do it in the web interface - just trying to go to Workflow Settings, I get "Error: Access Denied" for the current user. – RedMageKnight Jan 23 '15 at 15:13
0

Just to come back to this, we ended up figuring it out. Our database is on a separate server than our SP server and whoever set it up before I got here was trying to use the local network service account to authenticate workflows which wouldn't work when trying to access resources from that external database. We switched it to a domain account, gave it the appropriate permissions and workflows started working right away.

This is a link that inspired us to try this approach:

https://social.msdn.microsoft.com/Forums/en-US/85a498af-e7ae-416d-9f38-ae661e10c2d2/sharepoint-designer-workflow-you-do-not-have-permission-to-do-this-operation?forum=sharepointcustomizationlegacy

Either way, I hope this helps someone out or reminds me in the future if I run into this again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.