0

i'm newbie in Sharepoint
I'm using Sharepoint 2010. I have a workflow to create a 'Link to a Document' item to a Document Library.
I already set the 'Content Type ID' with Link to a Document. I'm sure that I set the 'Path and Name' and 'URL' correctly. But it won't happen and came out error. The workflow reports said "The workflow could not create the list item. Make sure the list exists and the user has permissions to add items to the list."
I'm sure that I have permission. So, why did I keep get error?

0

For a user to trigger an "on create" workflow, they have to have edit permissions to workflows.

Are you concatenating any fields? Specifically in the title field. Duplicate title names in the list or concatenating fields that aren't generated until after an item is created could be your culprit.

Can you specify the condition and action for your workflow that assigns this link?

  • Thanks for your assistance. I was create and edit the workflow as administrator. My workflow is assigned to create a folder in list B whenever I create a an Item in list A. It also create some link to document item in the folder that has been created before I already try to create a document (not a link document), and it works. It just failed when I try to create link to document item – dasmier Jan 21 '15 at 1:48
0

For those who get here: this error will happen when trying to create 'Link to a document' with spaces in 'Path and Name' field.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.