0

I've configured SharePoint to use FBA by specifying a membership and role provider in the site and STS's web.config.

However, when I sign using Forms Auth, I see this, below. I'm wondering what I need to do to give the signed in user access to the SharePoint site.

enter image description here

  • you have to configure, central administration web.config, sts web.config and site collection web.config The next link is a good guide to configure FBA link It's for 2010, but apply too to 2013 – Marco Jan 19 '15 at 20:59
  • There are problems in that article. For example, it says to set the default providers back to "i" and "c", yet, it shows the "Web Application (SharePoint – FBA) web.config" as having a default role manager that is not "c" but "FBARoleProvider." Following it exactly does not work. – Chris Jan 19 '15 at 21:11
  • that information is correct I have follow that guide a lot of time and always works for me. Just in case it say that the web app web.config need that change not other – Marco Jan 19 '15 at 21:23
  • Okay, thanks for your help. So which is it: should the default providers be "i" and "c" or "FBAMembershipProvider" and "FBARolePRovider" in "Web Application (SharePoint – FBA) web.config" (and other web.configs)? Which web.config(s) need to be specified with which Membership- and RoleProviders? – Chris Jan 19 '15 at 23:03
  • if you look at the end of the guide Donal give you an example of how the files (each one) have to looks like. For your question: <membership defaultProvider="i"> and <roleManager defaultProvider="c"> – Marco Jan 20 '15 at 13:40
0

If you're getting Access Denied, then the user you're logging in with simply hasn't been given enough permissions to access the SharePoint site. You'll have to login to the site as an administrator and add the user to a group with permissions (Site Owners, Site Visitors....). It could also be the url on the site you're trying to access. It might be to a Site Settings page that only site collection admins have access to (I noticed _layouts in the url, which made me think that might be why you're getting Access Denied). In that case clicking 'Go back to site' should take you back to the home page for the site, where the user might have the appropriate permissions.

Also, just an FYI, if you're getting this Access Denied page, then your membership configuration is correct and you shouldn't have to make any more changes to your web.config. If you had an incorrect web.config/setup issue, you would get an invalid username/password error instead of Access Denied.

  • I hadn't gone into Central Administrator and specified user policy (Full Read) for my SQL forms auth. provider. – Chris Jan 20 '15 at 14:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.