0

I have a really weird problem with a SharePoint App that deploys two workflows.

I have a deployment script that creates a web app, some sites and adds an app to the global app catalog. Once I try to install this app on any of my sites SharePoint blocks me saying my server does not support the application. If I upload the same app without the workflows I can install it without any trouble.

So far I've tried recycling all Workflow and Service Bus services as well as all app pools for any SharePoint web app. I've also tried IISReset to no avail. It still says my app is not supported. The only thing that seems to work is a complete reboot of the server. Once it comes back up I'm able to install the app.

My setup:

  • Server A: SP 2013 Enterprise, Workflow Manager (refresh), Visual Studio 2013
  • Server B: SQL Server 2012

I'm able to create and deploy workflows (2013) using SharePoint Designer both before and after the reboot.

Does anyone have any tips on why it requires a reboot? Is there some timer job running or a service recycle that I'm missing?

0

I discovered the problem. It seems that during deployment some services were not restarted correctly after IIS Reset. Once they were running the app could be installed.

Services:

  • Net.Pipe Listener Adapter
  • Net.Tcp Listener Adapter*
  • Net.Tcp Port Sharing Service*

*These services were also stopped, but did not affect the installation of the app. I have put them here because by default I think they should be running.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.