3

I have SP2013 foundation version. I am trying to create a result source but when I click on "Launch Query Builder", I am getting the following error :

"Not able to connect to search service to retrieve valid settings" when launching Query Builder in Central Administration

I have tried the following:

  • Give Administrator rights for the Search Service Application to the corresponding user (in Central Administration GUI or over PowersShell Commands)
  • Check if the Search Service Application is associated as a service connection to the Central Administration web application.
  • Can you check if the user which is trying to launch Query builder is Admin of Search Service Application? – Amit Jan 19 '15 at 5:50
  • yes user having full control and administrative privileges. – vijay shukla Jan 19 '15 at 12:37
  • I found in my case it was because I had two search service applications, deleted one and the query builder began working. – Lankymart Mar 23 '15 at 13:18
0

Please try executing the following command in SharePoint Server 2013 Management Shell as administrator and test the issue again:

Enable-SPFeature SearchWebParts -url http://<central admin url>
  • i already active this feature from central administrator. please confirm me i am having sp 2013 foundation version so its is possible to run search service application on foundation version. – vijay shukla Jan 19 '15 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.