0

I got this this error after setting up Search Service Application with Powershell.

The search service is not able to connect to the machine that hosts the
administration component. Verify that the administration component
'a23fd668-f823- 4ab2-b0fc-b0baebfd4af2' in search application
'SharePoint_Search_Service' is in a good state and try again.

The Sharepoint Search Service was showing error when I visited

Central Administration->Application Management->Service Applications-> Manage Service Applications

Here is the powershell script used

$App1 = "APP-Server-01"
$APP2 = "APP-Server-02"
$SearchAppPoolName = "SharePoint_SearchApp"
$SearchAppPoolAccountName = "EXSERV\Administrator"
$SearchServiceName = "SharePoint_Search_Service"
$SearchServiceProxyName = "SharePoint_Search_Proxy"
$DatabaseName = "SharePoint_Search_AdminDB"

Create a Search Service Application Pool

$spAppPool = New-SPServiceApplicationPool -Name $SearchAppPoolName -Account    
$SearchAppPoolAccountName -Verbose

Start Search Service Instance on all Application Servers

Start-SPEnterpriseSearchServiceInstance $App1 -ErrorAction SilentlyContinue
Start-SPEnterpriseSearchServiceInstance $App2 -ErrorAction SilentlyContinue
Start-SPEnterpriseSearchQueryAndSiteSettingsServiceInstance $App1 -ErrorAction  
      SilentlyContinue
Start-SPEnterpriseSearchQueryAndSiteSettingsServiceInstance $App2 -ErrorAction 
      SilentlyContinue

Create Search Service Application

$ServiceApplication = New-SPEnterpriseSearchServiceApplication -Partitioned -Name   
    $SearchServiceName -ApplicationPool $spAppPool.Name -DatabaseName $DatabaseName

Create Search Service Proxy

New-SPEnterpriseSearchServiceApplicationProxy -Partitioned -Name  
    $SearchServiceProxyName -SearchApplication $ServiceApplication
  • Can you please post the powershell script you tried with. – Amal Hashim Jan 16 '15 at 13:24
1

Possible Solutions

  1. Application Pool account don't have enough permission to access. Try changing the application pool to use SharePoint Web Services System
  2. Enable the timer job and RESET IIS
    • Get-SPTimerJob job-application-server-admin-service
    • Enable-SPTimerJob job-application-server-admin-service
    • Net Stop sptimerv4
    • Net Start sptimerv4
    • iisreset
  3. Ensure the account has full permission son the search service application.

Check this http://expertsharepoint.blogspot.com/2014/07/the-search-service-is-not-able-to_19.html

Search Service Application error

  • tried it, not working – Korede Lawrence Oluwafemi Jan 16 '15 at 14:12
  • let me mention also that I got an error while installing , Is there a way I can delete the installed search service application so as to try and install it again – Korede Lawrence Oluwafemi Jan 16 '15 at 14:23
  • I also got this error "Unable to retrieve topology component health states. This may be because the admin component is not up and running." – Korede Lawrence Oluwafemi Jan 16 '15 at 14:31
0

I actually discovered the reason for the errors, you need a domain account not a local account to create a search service application. Use an active directory created domain account to create the service appplication.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.