Currently I have 3 different SharePoint environments; DEV,UAT and PROD. These environments have same server topology and same software installations.

I populate some SharePoint lists and a SQL Server database with PowerShell. PowerShell script works fine under DEV and UAT. It also works well on PROD. However, whenever I run the script in the PROD, SharePoint site starts displaying;

Sorry, something went wrong

The context has expired and can no longer be used. (Exception from HRESULT:X80090317)

There is no such problem neither on DEV nor UAT. I assume that some configurations are different on the PROD but I couldn't find which ones they are.

What is the problem here? How can I avoid this?


Similar to the above answer but check if the web application time zone and the server time zone are identical, you could refer this article: Time zone issue

| improve this answer | |
  • They are not matching! Let me make them identical. Thanks – doganak Jan 16 '15 at 12:28
  • @Manu, the URL above is broken. Page not found. The time zone is the same in web application and server, but I am still getting the same error. – Imir Hoxha Aug 13 '15 at 14:46
  • It was fine when I posted, it seems they have moved the article here: support.cloudshare.com/hc/en-us/articles/… – Manu Aug 14 '15 at 15:50

The problem in my environment was that that it was because of default zone settings of the web application

Take a look of this link:The content has expired

| improve this answer | |
  • Yes, I know this is related to "default zone settings of the web application". But I don't change this configuration with script. It's already configured. – doganak Jan 16 '15 at 11:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.