5

Once the installer is started I can't click Install Prerequisites or Install SharePoint Foundation. The links don't work. Other links (ex. Read the Installation Guide) work fine. No messages, no further screens, just nothing. What happened? I tried to run Enterprise version and behavior is the same. I'm installing on a virtual machine with Win Svr 2008 and MS SQL 2008.

UPDATE: I tested it on Windows 7 to check if it starts. Links to installers doesn't work as well. I downloaded file again - no results. Has no one experienced this problem? I have administrator access on my machines - this is not the problem source.

  • i moved your update from the answer to your question. Please dont create answers instead of updating question – Anders Rask May 19 '11 at 13:31
3

Do you have User Account Control (UAC) activated on the server? Try right-clicking and making sure you run the installer as Administrator. Also make sure the account you are logged into the server with is a local administrator.

2

Have you tried installing the prereqs offline? http://blogs.msdn.com/b/mcsnoiwb/archive/2010/06/07/installing-sharepoint-2010-prerequisites-offline.aspx.

//Sorry, not enough rep to ask as comment.//

1

I've just encountered this problem.

The reason why the links didn't work for me was because I ran the installer on a 32bit version of Windows 2008.

SharePoint 2010 only supports 64bit operating systems (http://technet.microsoft.com/en-us/library/cc288751%28office.14%29.aspx). If you try running the installer on a 32bit OS, you'll see the same behaviour.

Although the initial part of the installer runs, nothing happens when you click on either one of the 'install' links. You won't see any messages or any indication as to why the installer has failed. Nothing happens at all.

In this scenario, the obvious answer is to make sure that you're using a 64bit version of Windows! I hope this helps someone who encounters this problem in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.