1

We have a SharePoint 2013 environment upgraded from SharePoint 2010. When working with Windows Explorer, users are able to navigate the folders normally without any issues. However, if a user tries to create a new folder from inside Windows Explorer, the process takes up to 30 seconds to complete and most of the time through the process the window shows "Not Responding". However, after that the folder is created normally. We did not face this issue in the previous SharePoint 2010 environment.

I have tried the various suggested solutions online like disabling "Automatically detect settings" in IE but that did not fix the issue. I also tried accessing one of the servers directly (i.e. not through NLB IP) and tried opening with explorer from inside the server and had the same behavior. The problem is only with creating folders.

Our environment is SharePoint 2013 with Windows Server 2012 R2. Our users are using IE9.I have also tested on IE 11 but the issue is also there.

Any idea what might be causing the problem?

Thank you.

  • I had similar problem an the error was in the webdav service of the iis. I didn't resolved it by myself, so all that I know was, that the it admin configured s.th. at the ldap server accessibiliy (or certificate handling). Because the main reason was the duration of the authorization. I don't know if there is a huge difference between creating a file or a directory. Maybe you have a similar error? – Sascha Jan 15 '15 at 7:21
  • Thank you Sascha. I have asked our IT to check the Active Directory for any similar case. I will update if they find any issues. – Moe Jan 15 '15 at 8:47
0

could be several issues but im going with WebDAV as that seems like the most common thing to cause delays is response in IE9+

http://www.microsoft.com/en-us/download/details.aspx?id=9981

taken from white papers above:

goto IE, Tools -> Internet Options -> Connections tab -> click LAN settings button and uncheck box next to Automatically detect settings and click OK.

enter image description here

what i presume is going on is that its trying to get the proxy settings before it makes a connection which make several failed attempts until it makes the connection and produces a success. I would expect you to see in fiddler several attempts being made to sharepoints version of WebDAV (not iis version)

| improve this answer | |
  • Thank you Ali, I have already tried disabling this option but got the same result. – Moe Jan 15 '15 at 10:41
0

It has been a while since I posted this, but in case anyone faces a similar issue, I have raised a case with Microsoft. It turned out that the slow performance was caused by a combination of two factors: using Document IDs and the large number of content types the library has. For each content type, SharePoint adds 4 event handlers to the library. When the new folder is being created, all the event handlers for all content types fire. The solution was either to disable Document IDs or reduce the number of content types in the library. Thanks.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.