WSS_Content log file which grown in GBs got deleted.

Now SharePoint sites showing 404 error. Using internal database SSEE. Any solution how can sites be running again.

  • Are you sure you only deleted the log file? – MackieeE Jan 14 '15 at 19:56
  • This way i am not able to restore sites. how ever now i have old wss_content_log.ldf file. NO ERROR SHOWN BY ABOVE PROCEDURE. In my case i used 100 In place of %number% – user38695 Jan 15 '15 at 10:04

You should have taken SQL backup before performing such changes.

To fix this you can try following

  1. Stop all SharePoint Services that are running
  2. Open command prompt and go to location "C:\Program Files\Microsoft SQL Server\%number%\Tools\Binn"
  3. Enter command sqlcmd -S \\.\pipe\mssql$microsoft##ssee\sql\query -E
  4. Now Detach Database using EXEC sp_detach_db [your_database_name]
  5. Now Attach Database using (No need to specify the ldf file in this case)
    • EXEC sp_attach_db @dbname = N'WSS_Content', @filename1 = N'D:\SharePointDB\WSS_Content.mdf'
  6. Exit and try restarting services
  • Sir above methods did not works. Sp_attach_db paths are as you typed or location of wss_content_adff... Like actual paths to files.sir i now have log.ldf file but older version. – purushotam Jan 16 '15 at 0:52

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.