2

I have created a sandbox solution with 2 custom lists, each with their own custom content type. When I deploy & activate the solution on my local environment and then activate the schema feature, both lists have been created, but they're both inheriting the same Content type. It seems that which ever content type is added 1st to the feature is the one that gets used.

When I try the same solution and process on a fellow employee's machine & local environment, they do not have the same problem? So is it something to do with my visual studio? Is this a common bug?

UPDATE: If I add the 2 list definitions to their own features, it works as it should. Ideally though I need only the 1 feature in order to activate everything.

2

I have encountered the same error today and spend half a day to solve it. In the end the answer from the question https://stackoverflow.com/questions/25857722/visual-studio-unexpectedly-adding-feature-on-load helped me.

If the lists in the same feature have the same Type ID, the tooling will move the lists into a newly created feature, because the Type must be unique within a feature. You can check the documentation on the ListTemplate element for more information.

Finally i had to give every list a unique template id and it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.