I'm experiencing the following error while trying to crawl a share:

Access is denied. Verify that either the Default Content Access Account has access to this repository

The default account has full control on the share, I also tried to manually mount the share with the crawl account and it is working.

Furthermore, looking into the ULS log I found an error on the function getnamedsecurityinfo error 5.

I can't figure out which is the problem the permissions look fine to me.


This issue can be fixed by

  1. Adding a crawl rule to crawl the file share
  2. Specify the same crawl account
  3. Check "Do not allow Basic Authentication"

Also make sure Loop back is disabled

New-ItemProperty HKLM:\System\CurrentControlSet\Control\Lsa -Name "DisableLoopbackCheck" -Value "1" -PropertyType dword
  • This does not solve the problem. I already tried adding a rule and I can't find the registry key you are referring
    – Kerby82
    Jan 9 '15 at 23:15
  • The exact error is: "CFileAccessor::Init GetNamedSecurityInfo returned 5
    – Kerby82
    Jan 9 '15 at 23:17
  • The registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa if doesnt exist you should create it in the WFE. Jan 9 '15 at 23:24
  • I guess that the problem is on the server containing the share. I have 20 content sources and just one is giving me such a problem.
    – Kerby82
    Jan 10 '15 at 0:03
  • For example I created another share on the server and I'm getting another error: The crawl account did not have ufficient privileges to access the security attributes of this file or folder. Ensure the crawl account has the 'Manage auditing and security log' privilege The permission are right I'm sure the crawling user has read and execute in permission and read in sharing tab
    – Kerby82
    Jan 10 '15 at 0:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.