1

We currently have a Search Application that was running normal until yesterday. I am not 100% sure when things went down but here is the scenario.

A new site collection was added to our server. During this time we stopped all currently running crawls. The site came up, we added some pages and such. We tested search and it worked.

This morning we restarted the crawls and search broke. The components and everything within Central Admin shows a green light, (All online, Nothing Recovering, etc). Crawls still process and complete normally.

When searching for an item such as "test" we receive a "Internal Server Error" with a Correlation ID, and time stamp. If we search for jibberish ("asde4cr") we receive the normal "No results found page").

Now if we do an "Index Reset" and DO NOT search the local SharePoint sites our search page populates normally.

What is causing items that are classifed as "Local" to cause the results page to crap out?

I have restarted IIS, checked permissions, changed permissions to see what happens, recreated the search, bounced the box and so on.

Here is the log blog I receive around the correlation ID

SearchBoxEx AfterDeserialize begin 742e3c50-063a-4d8b-ac96-51313ad9a961

SearchBoxEx AfterDeserialize end 742e3c50-063a-4d8b-ac96-51313ad9a961

FetchDataFromURL start at(outside if): 1 param: start 742e3c50-063a-4d8b-ac96-51313ad9a961

Filter category FASTMaxNumberOfFilters in the config is in wrong format.Input string was not in a correct format. 742e3c50-063a-4d8b-ac96-51313ad9a961

EDIT: It looks like the error is related to <Column Name="ContentClass"/>. If I:

  1. Modify the "Search Core Results" webpart on my results page
  2. Uncheck "Use Location Visualization"
  3. Remove <Column Name="ContentClass"/>
  4. Apply, Save and Close

Where is the "Location XSL" that I am unchecking located at? I feel like I can change that to solve my problem?

  • You should copy the correlation id and search the logs files for more information. – Amal Hashim Jan 9 '15 at 21:43
  • I added the block i see in the logs around the ID. – sealz Jan 9 '15 at 21:59
  • 1
    From the error one of the refiners on the result page has wrong value for FASTMaxNumberOfFilters. You can edit the refiner panel properties and review the XML. – Amal Hashim Jan 9 '15 at 22:09
  • @Amal Hashim We are not using FAST so we do not have that option in the config. This does look promising though. Is there another setting it could be tied too? – sealz Jan 12 '15 at 14:26
  • I also tried to remove the Refinement panel from the page but I still get the internal error when searching. So I'm guessing this rules out that as the culprit? – sealz Jan 12 '15 at 14:30
0

It looks like the error is related to <Column Name="ContentClass"/>. The problem seems to date back further than I expected. I am not 100% sure but it seems changes made by other people to the search criteria (Scopes, metadata, etc.) caused this specific type of information to be lost and no longer related to the results.

I simple modified the core results webpart to leave that column out of the fetched properties.

The steps are as follows:

Modify the "Search Core Results" webpart on the results page
Uncheck "Use Location Visualization"
Remove <Column Name="ContentClass"/>
Apply, Save and Close

Ideally the long term fix is to rebuild the search or back track through the fields to make sure everything is still there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.