4

We're using the default internal site on SharePoint Online. When going through the setting I'm missing the section for Web Designer Galleries specifically the Solution Gallery. Is there a way to enable this option on the default site?

Alternatively I can access the Solution Gallery by adding the direct path.

https://SPO.sitecollection.com/_catalogs/solutions/Forms/AllItems.aspx

The only issue I have with this is every time I try to upload a solution I get a message that pops up say I require access to the site, but I'm the Site Collection Administrator. When I send a request I go and approve my own request, but still no luck.

Is there a way for me to enable this setting on the default internal site or grant access to Solution Gallery?

  • It didn't work for me. I ran the command and get a "Set-SPOsite : The request uses too many resources." Can you help? – Chau Le Apr 10 '19 at 23:36
  • I would review you Server Resource Quota in the SharePoint admin center. See if you might need to increase the resources for your site. – zingwing Apr 11 '19 at 18:00
3

I end up getting this issue resolved. I had to enabled scripting capabilities.

I followed this guide

  1. Sign in to Office 365
  2. Go to the SharePoint admin center
  3. select settings
  4. Under Custom Script:
  5. Change both options to "Allow users to run custom subscription on..."

It takes roughly 24 hours for the change to take effect on O365

I have found additional information what will speed up the process. guide2

Proceeding from the steps above you will need to download the SharePoint Online Management Shell

Run the following commands below, replacing "contoso" with your company name. Also the set-sposite command will point to the site collection you want to enable scrpting on.

  1. Connect-SPOService -Url https://contoso-admin.sharepoint.com
  2. set-sposite https://contoso.sharepoint.com -denyaddandcustomizepages 0

After the command has run, you should be able to access everything instantly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.