4

I have a SharePoint 2013 that is setup in anonymous mode (at the web app level and then at the site level; the Entire Web site is being exposed as anonymous). I then have the "lock-down mode" feature enabled so that anonymous users cannot get to system pages. Additionally, I have disabled the Client Integration feature at the web app level, so that documents are forced to be downloaded.

I'm having an issue (that is pretty well documented online with other folks having this issue) where users try to open XLSX documents and an authentication prompt is being rendered. Regardless of whether valid credentials are entered, the excel document never opens and just shows a 401 unauthorized error.

I've tried everything in this article (break permissions, disable lock-down mode, and/or add the 'open items' permission to anonymous permission level)

I've also tried enabling the "Open Documents in Client Applications by Default" feature at the site collection level. This also does not solve the problem.

All other document types, including XLS, open as expected.

-1

create an Excel Services Application and start the service on at least one machine in the farm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.