3

I'm unable to set item level permissions on list items. This issue appears for all lists in a site. Take a look at the screenshot. Usually a "Advanced" button should appear in position of the red line. The "Working" icon is also visible, I tried to let it work for a couple of minutes - but nothing happen.

Screenshot 1

Any ideas?

  • is it online or on-premise? – Amal Hashim Jan 7 '15 at 14:11
  • on premise (SharePoint 2013 @ CU 11/2014) – Alex Jan 7 '15 at 14:14
  • Can you see anything on the Log Files? – Amal Hashim Jan 7 '15 at 14:16
  • no, nothing special. But I see in the console following Java Script msg. Uncaught Error: The property or field has not been initialized. It has not been requested or the request has not been executed. It may need to be explicitly requested. – Alex Jan 7 '15 at 14:30
  • Can you try a different browser or enable the compatibility mode in IE? – Amal Hashim Jan 7 '15 at 14:31
5

I ran into this issue myself just recently. I found a related thread over at Microsoft's forums:

https://social.technet.microsoft.com/Forums/office/en-US/c9703b7b-a719-48b4-9350-9d9a75ac62e1/list-item-shared-with-dialog-error?forum=sharepointgeneral

The answer for me lied there in one of the suggested answers by the user Martin B.

One thing to note, however, is that Martin had changed his web.config file to debug mode, and thus recommended making the suggested changes in "sharing.debug.js". You actually would want to make this in the "sharing.js" file (I went ahead and made the change in both files). Here's a summation of the changes you'd want to make in each:

In "sharing.js", the following code:

k.load(g,"ID","FileRef","FileLeafRef","Client_Title");

was replaced with:

k.load(g,"ID","FileRef","FileLeafRef","Client_Title","Title");

And in "sharing.debug.js", the following code:

cctx.load(listItem, 'ID', 'FileRef', 'FileLeafRef', 'Client_Title');

was replaced with:

cctx.load(listItem, 'ID', 'FileRef', 'FileLeafRef', 'Client_Title', 'Title');

Some additional information:

1) Make backups of these two files before changing them.

2) Another post in that Microsoft thread, by user Kelly, suggested they were able to trace this back to a SharePoint Server update from November, KB2899508. Unfortunately, I had updated all my production, test, and development environments mid-December, and had no readily available environment where this update was not already installed to go back and verify this yet myself.

3) You may need to wait a few minutes to see the change take effect. You can use webdev tools to see if the "sharing.js" file being loaded has your new changes. My test environment responded immediately to a simple Ctrl+F5 refresh, but for whatever reason, my production environment just insisted on keeping the old one cached (through refreshes and browser restarts) for ~5 minutes.

  • great, worked for me – Alex Jan 12 '15 at 8:38
  • Thanks for the solution, @Jordan. You saved my time from figuring this out myself. – Mihail-Florin Popa Feb 10 '15 at 16:55
  • Great Solution :) – Grzegorz Z Jun 22 '16 at 11:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.