1

I am having what I believe is the same issue as described in Workflow association with the list is not recognized by SharePoint, but the solution there is not working for me.

I have a fairly basic custom list. In SharePoint Designer, from the settings page for that list, I clicked New > List Workflow, and created a very simple workflow. On the workflow's settings page in SPD it indicates that it is associated with my list. But if I click "Open associated list", my workflow does not appear on the list's settings page. I did Save and Publish the workflow, and I also tried closing and relaunching SPD, etc. At no point did I receive any error messages.

If, from the list's settings page, I try to "Associate Existing Workflow", the workflow I created doesn't appear as a choice there either.

What am I doing wrong?

0

It turns out that my problem was due to a corrupted installation of SharePoint Designer. Anytime I attempted to publish a workflow where the initiation form had to be generated, SPD would fail, without an error message, to publish. The first clue was that the workflow's "publish" process took almost zero time to (appear to) complete, which I didn't know was unusual until I ran a publish operation on an existing workflow, without making any changes, which took about 5 seconds to do.

So the reason the workflow didn't appear on the list settings page is that it never actually published. A full uninstall, reboot, and reinstall fixed the problem.

0

Actually I have found the cause of this issue ( which is extremely frustrating ) is due to the local cache on the computer getting corrupted. This appears to happen more often if you are working either over a VPN or SharePoint Online. Something to do with bandwidth.

Although your fix solved the problem there is an easier way. so:-

  • Close SPD if it is open.
  • Open My Computer or explorer. Click the address bar.
  • Paste in: %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache.
  • Delete everything within this location.
  • Actually I did try that a couple of times, to no avail. – Dan Henderson Aug 16 '17 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.