1

I am using SP2013 on-premise. On a site collection's Pages library there is a Managed metadata column "Wiki Category" and allowed mulitple values. At the same time I have enabled multiple values for a managed property "ows_taxId_Wiki_x0020_Page_x0020_Categories".

However, the crawl log for most pages return error:

The content processing pipeline failed to process the item. ( Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index; ; SearchID = E2DFE16B-1234-4F1A-4567-02552018E642 )

According to SP2013, full crawl error: The content processing pipeline failed to process the item. ( Index was out of range. Must be non I think I did it correctly. What else could lead to the error? I have tried remove the Managed metadata column and the search is fine.

1

Please check the ULS log with the Search ID. You might find more information in the Logs. I faced a similar issue, and after checking the ULS logs, I found that 'ExcludeFromSummary' is mis-configured.

Check this article if it helps - http://spdeveloper.co.in/sharepoint2013/search-crawl-content-processing-pipeline-failed.aspx

| improve this answer | |
  • Ram, I have read your article before. I have tried uncheck the "allowed mulitple values" for both the MP and the site column. The search will go smooth. However I need the column to allow mulitple values. What can I do? – Mark L Jan 5 '15 at 4:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.