0

I am making changes to several SharePoint state machine workflows that each contain Infopath forms for the workflow tasks. I have been able to deploy all but one of them successfully. The problem I am having is that the forms in the workflow are not pushed to the Manage Form Templates section of Central Admin. For all the other workflow projects, installing the workflow using a .bat file worked fine, and updated the form templates.

The first time I tried to deploy this workflow, the forms did not change at all in CA. I saw errors when attempting to upload new versions manually

"The following form template cannot be upgraded because it is not currently uploaded on this farm"

I uninstalled the feature that contained the forms, which deleted them, but on all subsequent deploys of completely new versions/GUIDs for everything, the forms don't get add to the template list in CA. If I try to upload the templates manually in CA, the forms have a value of No for Workflow Enabled, which prevents me from opening them in SharePoint.

I have researched for many hours with no solution. I have read and completed step-by-step the following articles:

The structure of my project folder in 14/TEMPLATES/FEATURES is:

  • Forms folder (includes all .xsns, elements.xml and workflow.xml)
  • Workflow1 folder (includes elements.xml)
  • Feature.xml

If anyone could give advice that would be great.

  • Anyone? Should I change the tags? ?? – Paul Jan 2 '15 at 15:25
0

This is a tricky problem but I found the solution. In my SharePoint workflow project in Visual Studio, the .xsn in my Forms folder was not a "published" Infopath form. I didn't have access to the SharePoint server (my Infopath install was on a different VM) so I was just saving the Infopath template and sending it to the other VM.

This can cause your template to not be added to Central Admin. So the fix for me was to publish the form to a network location. Make sure you clear the alternate access path in the wizard. After deploying the .WSP, my form was added to Central Admin "Manage Form Templates" with a value of Yes for Workflow Enabled.

Also verify the following:

  • The security level of your form is Domain or Full Trust.
  • You have the "GloballyAvailable" and "RegisterForms" settings correctly set in the feature manifest (see here)
  • Your Form URN is correct in the Workflow1/Elements.xml file (and workflow.xml file if applicable).

This blogpost is also a good checklist for this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.