1

I've tried several steps from other questions. After removing the service instance and running the command Add-SPDistributedCacheServiceInstace I receive the error:

Add-SPDistributedCacheServiceInstance : ErrorCode:SubStatus:No such host is known

The AppFabric Caching Service is running and the service will show up under services after running the command, but cannot be started.

Running the command Get-CacheHost gives:

HostName: ServerName

CachePort: 22233

ServiceName: AppFabricCachingService

Service Status: UNKNOWN

Version Info: 0 [0,0][0,0]

This is a staging environment with one sharepoint server and one sql server

  • Have you seen this article blogs.msdn.com/b/sambetts/archive/2014/03/19/… ? – Amal Hashim Dec 30 '14 at 21:20
  • Yes, when I run those commands the server is correct for the serviceinstance, but the hostname for Get-CacheHost is incorrect. When I use the Add-SPDistributedCacheServiceInstance the incorrect server name is what gets set – MickB Dec 30 '14 at 21:58
0

Another server was originally setup as the cache host for the farm. It had since been removed, but the cache host was never reconfigured. I unregistered the cache host and registered it using the correct server credentials.

Once this change was made, running the Add-SPDistributedCacheServiceInstance cmdlet resolved my issue. Thank you Amal Hashim for pointing me in the right direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.