I am getting following error while deploying the sharepoint app

"Error 1 CorrelationId: 2f46bcef-ae89-4cde-80ca-273a0c1f8ac9
ErrorDetail: Apps are disabled on this site.
ErrorType: Configuration
ErrorTypeName: Configuration
ExceptionMessage: Microsoft.SharePoint.SPException: Apps cannot be installed. Review the diagnostic logs for more details regarding app deployment failures.
at Microsoft.SharePoint.Utilities.SPUtility.ThrowSPExceptionWithTraceTag(UInt32 tagId,
ULSCat traceCategory, String resourceId, Object[] resourceArgs)
at Microsoft.SharePoint.Packaging.SPUserCodeSolutionDeploymentGroup.Deploy()
at Microsoft.SharePoint.Administration.SPAppTask.DeployOperation()
at Microsoft.SharePoint.Lifecycle.MonitoredTaskExecution.DoTask()

Source: AppWeb

SourceName: App Web Deployment

Error occurred in deployment step 'Install app for SharePoint': Failed to install app for SharePoint. Please see the output window for details.

========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========

========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

  • Are you trying to deploy the App from Visual Studio? Dec 30, 2014 at 13:55

2 Answers 2


Create an isolated app domain on your development computer Microsoft has provided also some PowerShell command to configure your SharePoint (link).

  1. Start the SharePoint 2013 Management Shell.

    • net start spadminv4
    • net start sptimerv4
  2. Create your isolated app domain your apps, for example "apps.developement.local".

    Set-SPAppDomain "apps.developement.local"
  3. Ensure that the SPSubscriptionSettingsService and AppManagementServiceInstance services are running.

    Get-SPServiceInstance | where{$_.GetType().Name -eq "AppManagementServiceInstance" -or $_.GetType().Name -eq "SPSubscriptionSettingsServiceInstance"} | Start-SPServiceInstance
  4. Verify that the SPSubscriptionSettingsService and AppManagementServiceInstance services are running.

    Get-SPServiceInstance | where{$_.GetType().Name -eq "AppManagementServiceInstance" -or $_.GetType().Name -eq "SPSubscriptionSettingsServiceInstance"}
  5. You must specify a farm admin account under which the SPSubscriptionService and AppManagementServiceInstance services will run. This farm admin account must be a SPManagedAccount. If your farm admin is not a SPManagedAccount, you can create a SPManagedAccount with your farm admin credentials by typing the following command in the SharePoint Management Shell (You will be prompted for the farm admin domain\user and password).

    $account = New-SPManagedAccount
  6. Specify a farm admin account, application pool, and database settings for the SPSubscriptionService and AppManagementServiceInstance services.

    $account = Get-SPManagedAccount "domain\user"
    $appPoolSubSvc = New-SPServiceApplicationPool -Name SettingsServiceAppPool -Account $account
    $appPoolAppSvc = New-SPServiceApplicationPool -Name AppServiceAppPool -Account $account
    $appSubSvc = New-SPSubscriptionSettingsServiceApplication –ApplicationPool $appPoolSubSvc –Name SettingsServiceApp –DatabaseName SettingsServiceDB 
    $proxySubSvc = New-SPSubscriptionSettingsServiceApplicationProxy –ServiceApplication $appSubSvc
    $appAppSvc = New-SPAppManagementServiceApplication -ApplicationPool  $appPoolAppSvc -Name AppServiceApp -DatabaseName AppServiceDB
    $proxyAppSvc = New-SPAppManagementServiceApplicationProxy -ServiceApplication $appAppSvc
  7. Specify your tenant name by typing the following code in the SharePoint Management Shell.

    Set-SPAppSiteSubscriptionName -Name "app" -Confirm:$false

After you deploy a SharePoint-hosted app, you may be prompted to log in when you try to launch it and may receive error 401. The solution is to Disable Loopback Check. It requires editing registry settings in your dev env (windows server 2008). Below are the steps to do so:

  1. Backup registry.
  2. Run REGEDIT (via cmd or start menu)
  3. Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters. Here, Add DWORD registry value DisableStrictNameChecking and set it to 1 with base type Decimal.
  4. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa. Here, Add DWORD registry value DisableLoopbackCheck and set it to 1.
  5. Now, Restart the machine.

This error states that APPS are not setup on your farm.

Check this http://msdn.microsoft.com/en-us/library/fp179923(v=office.15).aspx

  1. Ensure that the app management service and user profile application are configured.
  2. Ensure that at least one profile is created in the User Profile Service Application.
  3. Create an isolated app domain on your development computer
  4. Add your isolated app domain to your bypass list in Internet Explorer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.