I have a CQWP that shows content from a list. Initially the standard limit of 15 elements was applied but now the need was to show all.

Problem is that only every 5 or 6 times the web part shows up correctly, even though it works fine if you choose to edit (and don't change anything) and then leave edit mode. Not all users can edit the page though (and should not be able to) in order to read the rest of the elements...

Any good ideas as to why this happens?


Could caching be involved?

  • I thought so but the problem keeps appearing so no reboots or anything seems to help – noesgard Jan 26 '10 at 15:05

Could it be that you have personalized the page e.g. you modified the web part settings, but this was not done in the Shared View?

  • The pages has been edited in shared view (that's what we did to remove the limit). Doesn't seem to be the cause – noesgard Jan 27 '10 at 7:19

Agree with Mike that this sounds cache related.

If its server side cache you could flush object and disk based cache (object should be enough really) under Site Actions > Site Settings > Site Collection administration

if its client based try reloading the page with CTRL- F5 to flush client cache.

I can also recommend using Fiddler or VRTA or similar to analyze headers of the response from server to see if cache is involved.

hth Anders Rask

  • Caching was not enabled on this site, could it still be server side caching issues? I'm not familiar with Fiddler etc. how would I determine if chaching is involved using that tool? – noesgard Jan 27 '10 at 7:27
  • Checking server and client cache settings is done in the SA > SS > SCA > Site Collection Output Cache. If this is enabled check what the anonymous and authenticated cache profile is set to. Then check what that profile (eg Extranet) is configured as: SA > SS > SCA > Site Collection Cache Profiles. For example a Caceability setting of Private will translate to a "Cache-Control: private" in your response header telling the client (but not a proxy server) that its ok to cache the page. Duration in cache profile will translate to something like "Expires: Tue, 12 Jan 2010 09:07:35 GMT". – Anders Rask Jan 27 '10 at 9:15
  • In Fiddler you see the response and request headers by selecting the Inspectors tab and select Headers tab in request and response. hth Anders – Anders Rask Jan 27 '10 at 9:16
  • caching was not enabled serverside as far as I could see – noesgard Jan 27 '10 at 14:23

Has anyone discovered the answer to this? I am having the same problem. The limit is not set in my CQWP, but it only displays 9 items. When I go into Edit it displays everything (more than 9). When I discard checkout it displays everything for a few minutes, then 9 again shortly thereafter. I have tried deleting the webpart and inserting a new one. I have even deleted the entire page and rebuilt that. Same result.

  • Nothing new so far but I'm glad that the problem is known somewhere else too... – noesgard Mar 19 '10 at 7:36

I am having same issue as Brian. I am only getting 9 items showing. Go into edit page, everything displays. Go into browser and all items show for a bit, then goes back to displaying 9.

Any ideas would be appreciated.

  • I seem to have gotten around the problem of only having 9 items in the content query. Just set a filter on one of the fields that will be true of all itmes. In my case, the CQWP was being used for published articles, so I just filtered the documents by article date being greater than the oldest date of the publications. So far so good. All docs are still showing. Hope this helps. – Anonymous Oct 19 '10 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.