1

I have made changes to my custom CSS on the SharePoint portal using SharePoint Designer, then I saved it. I went to check on the portal, however the changes I made were not applied. I checked the CSS using Chrome's developer tools and I was modifying the correct sheet but the changes I made were not included there. why is SharePoint not applying the changes I made to CSS?

I checked in the CSS then checked it out but nothing seems to work. It is already published.

I researched and found that I should clear BLOB cache? How do I do this exactly? I'm afraid this may affect the server so I'd rather not do it since I'm new to SharePoint development.

Why are the changes not applied? Is there any other way to fix it without clearing the BLOB cache?

UPDATE: So what I did now was create a new style sheet and reference it in the master page. It shows on developer tools but when I view the code, nothing is there!!

  • 3
    I guess you have cleared the browsers cache? – Robert Lindgren Dec 28 '14 at 13:26
  • Are you trying to overwrite the predefined css of SharePoint or it is completely a new one ? – Akarsh Gupta Dec 28 '14 at 20:04
  • yes, I've cleared the cache. I'm trying to overwrite custom made css. I have modified it. I'm assuming it's published since the publish button isn't enabled. – else Dec 29 '14 at 4:39
  • UPDATE: so what I did now was create a new style sheet and reference it in the master page. It shows on developer tools but when I view the code, nothing is there!! – else Dec 29 '14 at 4:43
  • try the suggestions in the blog sharepointnutsandbolts.com/2011/11/… by Chris O'Brien – Amit Dec 29 '14 at 5:11
0

Where did you specify the tag referring your custom CSS?if its not specified in the head tag of the your Master page's html ,it will not apply the styles.When you are editing the Mater page and when you select the option of insert a style sheet in designer,the reference to the style sheet is not placed in the head tag,instead some where in the middle of of your Mater page's html.Try refering the link tag in the head tag of your Master page's html.This suggestion is from my beginner level's experience.

  • It was specified in the header tag. I think it is not published. I tried accessing its link but it gave me page not found. How can I publish it if the publish button is disabled? – else Dec 29 '14 at 7:05
  • If its something about publishing issue and you are unable to publish with publish button,go through this experts-exchange.com/OS/Microsoft_Operating_Systems/Server/… – noah_dvlpr Dec 29 '14 at 7:13
0

have been stuck with it several times when composing my javascript in sharepoint designer, not sure why it works like that, but clear the cache of sharepoint designer will do the trick sometimes.

http://www.c-sharpcorner.com/UploadFile/sagarp/how-to-clear-your-sharepoint-designer-20102013-cache/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.