1

I am trying to open SharePoint Online site with my designer but I am getting below error:

There is a problem with your account please try again later

Can anyone please let me know the possible cause of this issue.

  • I had the same issue once with 2010. I had inadvertently turned on kerb Eros authentication for the site in cenrral.admin. turning that off and using AD authentication resolved the problem. – Robbert Dec 27 '14 at 17:21
  • @Robbert: I am using SharePoint online so i don't have access to central admin – Amit Dec 29 '14 at 4:16
2

In SharePoint Designer, on the account page, you can change which account you sign in with. It may be that you have connected to another service with different credentials than this one. If so, just switch accounts on the accounts page.

enter image description here

  • Hi Benny, Thanks for the response. I tried switching account but after providing password it gives me same error message. I can login to site in browser using the same password but not able to connect using designer. – Amit Dec 26 '14 at 11:18
  • @amit You should add an account from tenant you are connecting to. If you are connecting to multiple SPOnline tenants, you'll have to have at least one account associated in SPD from every tenant. (don't forget to restart SPD after adding new account). – Benny Skogberg Dec 26 '14 at 12:57
  • The account i am trying to add is site collection admin still i am having same issue. – Amit Dec 29 '14 at 5:39
1

I just posted this in a similar thread here.

Basically I did everything people suggested here, but then also edited some registry keys under HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Identity

Link to where I found information on what keys to delete here. Link to where I found what key to add here.

This seemed to become and issue once my organization turned on multifactor authentication on my O365 account.

  • Welcome to SE:SharePoint! Your answer appears to have some helpful links. Please consider writing a summary of what the links contain so that if they get broken, the information here will still be enough to help future users. – thanby May 14 '18 at 21:38
  • This one worked. Added 2 registry keys , As @BridgetM said for Identity and the other one was for EnableADAL and set the values to 1 each. – Murtuza Husain Mar 27 at 10:12
0

Whether this issue occurred for other SharePoint Online sites.

Clear the local cache files to see if it helps:

  1. Close SharePoint Designer 2013
  2. On the local computer, browse to the following folder: C:\Users\\AppData\Local\Microsoft\WebsiteCache
  3. Delete all the folders that are present
  4. On the local computer, browse to the following folder: C:\Users\\AppData\Roaming\Microsoft\SharePoint Designer\ProxyAssemblyCache
  5. Delete all the folders that are present
  6. Open SharePoint Designer 2013 and enter the account again to see if it works.
  • I Navigated to websiteCache folder but it is empty and I cannot locate ProxyAssemblyCache folder. – Amit Dec 30 '14 at 9:01
  • Whether this issue occurred for other sites. – Kally_MSFT Dec 30 '14 at 9:20
  • Yes. But is it working fine on my colleagues machine and throwing error on my machine. Not sure why. – Amit Dec 30 '14 at 9:29
0

You can use fiddler to track the SharePoint web request and compare it to the request in your colleague's environment. Probably with account permission issue.

http://www.telerik.com/fiddler

  • Hi all, below url came to my rescue community.office365.com/en-us/f/172/t/165027.aspx some proxy settings of my organization was preventing site from opening in designer. Now its resolved. Thanks all for help and efforts. – Amit Dec 30 '14 at 11:37
  • Hi Amit, could you help me with this issue. I am facing the same problem with SharePoint Designer. And the above link is not valid now. – Sid Sep 14 '17 at 1:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.