I am trying to open SharePoint Online site with my designer but I am getting below error:

There is a problem with your account please try again later

Can anyone please let me know the possible cause of this issue.

  • I had the same issue once with 2010. I had inadvertently turned on kerb Eros authentication for the site in cenrral.admin. turning that off and using AD authentication resolved the problem.
    – Robbert
    Commented Dec 27, 2014 at 17:21
  • @Robbert: I am using SharePoint online so i don't have access to central admin
    – Amit
    Commented Dec 29, 2014 at 4:16

8 Answers 8


In SharePoint Designer, on the account page, you can change which account you sign in with. It may be that you have connected to another service with different credentials than this one. If so, just switch accounts on the accounts page.

enter image description here

  • Hi Benny, Thanks for the response. I tried switching account but after providing password it gives me same error message. I can login to site in browser using the same password but not able to connect using designer.
    – Amit
    Commented Dec 26, 2014 at 11:18
  • @amit You should add an account from tenant you are connecting to. If you are connecting to multiple SPOnline tenants, you'll have to have at least one account associated in SPD from every tenant. (don't forget to restart SPD after adding new account).
    – Benny Skogberg
    Commented Dec 26, 2014 at 12:57
  • The account i am trying to add is site collection admin still i am having same issue.
    – Amit
    Commented Dec 29, 2014 at 5:39

I just posted this in a similar thread here.

Basically I did everything people suggested here, but then also edited some registry keys under HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Identity

Link to where I found information on what keys to delete here. Link to where I found what key to add here.

This seemed to become and issue once my organization turned on multifactor authentication on my O365 account.

  • 1
    Welcome to SE:SharePoint! Your answer appears to have some helpful links. Please consider writing a summary of what the links contain so that if they get broken, the information here will still be enough to help future users.
    – thanby
    Commented May 14, 2018 at 21:38
  • This one worked. Added 2 registry keys , As @BridgetM said for Identity and the other one was for EnableADAL and set the values to 1 each. Commented Mar 27, 2019 at 10:12
  • Well, here I am 3 years later, with a new laptop, but the same problem and the steps I used then are not working now.
    – BridgetM
    Commented Sep 14, 2021 at 18:15

Whether this issue occurred for other SharePoint Online sites.

Clear the local cache files to see if it helps:

  1. Close SharePoint Designer 2013
  2. On the local computer, browse to the following folder: C:\Users\\AppData\Local\Microsoft\WebsiteCache
  3. Delete all the folders that are present
  4. On the local computer, browse to the following folder: C:\Users\\AppData\Roaming\Microsoft\SharePoint Designer\ProxyAssemblyCache
  5. Delete all the folders that are present
  6. Open SharePoint Designer 2013 and enter the account again to see if it works.
  • I Navigated to websiteCache folder but it is empty and I cannot locate ProxyAssemblyCache folder.
    – Amit
    Commented Dec 30, 2014 at 9:01
  • Whether this issue occurred for other sites.
    – Kally
    Commented Dec 30, 2014 at 9:20
  • Yes. But is it working fine on my colleagues machine and throwing error on my machine. Not sure why.
    – Amit
    Commented Dec 30, 2014 at 9:29
  • Can u try my above answer? that was worked for me.. Commented Nov 26, 2019 at 22:48

You can use fiddler to track the SharePoint web request and compare it to the request in your colleague's environment. Probably with account permission issue.


  • 1
    Hi all, below url came to my rescue community.office365.com/en-us/f/172/t/165027.aspx some proxy settings of my organization was preventing site from opening in designer. Now its resolved. Thanks all for help and efforts.
    – Amit
    Commented Dec 30, 2014 at 11:37
  • Hi Amit, could you help me with this issue. I am facing the same problem with SharePoint Designer. And the above link is not valid now.
    – Sid
    Commented Sep 14, 2017 at 1:41

open windows powershell ISE and run as administrator (download "sharepoint online management shell" and once installed, you can find the windows powershell ISE)

Step1:enter image description here

Step2: Connect to the sharepoint online admin home with the login credentials. Type the following command along with the login username of the sharepoint online, and press enter, it will pop-up for login password. enter image description here

enter image description here

Step3: After entering your login credentials, we need to enable the feature of scripting

enter image description here

Step4: run set-sposite -denyaddandcustomizepages 0 to enable the feature of scripting enter image description here

Step5: Press enter and wait

enter image description here

When you see “ps c:\windows\system32>” prompts up, it means the feature is enabled. now you can check if you can enter your team site with the sharepoint designer 2013


I had the same problem and it was related to two-factor authentication. I solve it by generating app password on page https://portal.office.com/account. When you generate this unique password phrase then just use it instead you original password.


Even I had the same issue, I tried all the options of previous and it was not working for me.

Then the following is worked for me:

Uninstall 64 bit version of SPD2013 and installed SPD2013-32 bit version of it

then install sharepoint designer 2013 sp1(service pack).

Now its working for me. Let me know you if anything


I had tried all the fixes mentioned and nothing worked for me.

For some reason, signing in to the site with Internet Explorer, then restarting SPD, fixed it (not Edge).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.