0

We have a dev environment where there are two sources for resolving names in people pickers. The spelling of the name gets corrected when you enter domain\user, but then it states there are no matches. When you click on the name two sources appear for the user (see image). We completed deleted the UPS and recreated it but are having the same problem. The incorrect one is the "STS De 2" item in the image. I am not sure where this is coming from. Any help is appreciated.

Also, I configured the USP and AD connections exactly the same as our prod environment, down to the users/groups selected for syncing. The prod environment does not have this problem

enter image description here

In case you can't make out the user in the picture, it is "domain-name\Domain Users"

1

Verify you don't have multiple authentication (identity) providers defined for the Web Application in DEV, so basically this screen should only have one provider selected.

http://blogs.msdn.com/b/sridhara/archive/2010/01/07/setting-up-fba-claims-in-sharepoint-2010-with-active-directory-membership-provider.aspx

Image source

  • we did have a trusted identity provider. It was not checked, but I went ahead and toggled the setting anyway just in case. Then, I found that the people picker names would not resolve. Not sure if it is unrelated, but I compared the people picker searchforest property settings in prod (No Property Exists) to dev, and dev had a searchforest setting. I cleared this and the names are resolving now. Thanks!! – steveareeno Dec 18 '14 at 13:51
0

How many AD connections do you have in your UPS?

If this a migration try migrating the users:

$w = Get-SPWebApplication “http://yoursharepointsite.com/”
$w.MigrateUsers($True)

You can also try to delete the obsolete users and groups (from here)

$upa = Get-spserviceapplication <identity>
Set-SPProfileServiceApplication $upa -GetNonImportedObjects $true #views objects
Set-SPProfileServiceApplication $upa -PurgeNonImportedObjects $true #deletes objects

Try resetting the sync database, and running a full sync.

$syncdb=Get-SPDatabase <SyncDBGUID>
$syncdb.Unprovision()
$syncdb.Status='Offline'
$upa=Get-SPServiceApplication <UPSAppGUID>
$upa.ResetSynchronizationMachine()
$upa.ResetSynchronizationDatabase()
$syncdb.Provision()
0

The incorrect one might be coming from the User Information list. Try deleting the user from there. It should fix your problem.

You can refer this for the powershell script to be used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.