0

While investigating why alert emails weren't going out, I discovered that the Immediate Alerts jobs were associated with a WFE server. On that server, the SharePoint Timer Service had been disabled (intentionally, we only have it enabled on the app servers).

I enabled and started the service, and all pending alerts went out.

How can I change the jobs so that they don't try to use a service that's disabled?

1 Answer 1

1

The timer service is for all administrative, deployment, and services from a very high level, including updating configuration and those servers to the farm. Turning the timer service off can be problematic.

If you want emails to go out on a specific server, enable the SMTP service and follow this guide to set up SMTP and the configuration that goes along with it. You can probably disable the SMTP server that the WFE service is in.

2
  • Thanks, so you'd recommend enabling the timer service on all servers in the farm, including WFEs?
    – Joe
    Dec 18, 2014 at 13:09
  • Yes. I wouldn't permanently stop the timer service for any reason, but sometimes the timer service needs to be restarted.
    – Mike
    Dec 18, 2014 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.